Alle samlinger
Integration
Fragtmodul
Shopify - Shipmondo app begrænsninger
Shopify - Shipmondo app begrænsninger
Nicklas Nguyen avatar
Skrevet af Nicklas Nguyen
Opdateret over en uge siden

Shipmondo app for Shopify har nogle begrænsninger, som skyldes manglende understøttelse i Shopifys API. Disse mangler hos Shopify medfører, at Shipmondo appen i nogle brugsscenarier ikke fungerer hensigtmæssigt.

Herunder kan du læse om disse scenarier/begrænsninger:

Fragtgrænser baseret på kurvens totalpris og rabatkoder

Problem:

Benytter du fragtgrænser baseret på kurvens totalpris (Order amount based) med Shipmondo appen vil du opleve at Shipmondo appen ikke tager højde rabatkoder i sin prisberegningslogik.

Årsag:
Problemet skyldes, at Shopify API ikke videregiver informationer om rabatter i checkout til os. Dermed får vi kun opgivet den samlede normalpris eksklusiv eventuelle rabatter.

Status:​
Vi rykker jævnligt Shopify for at få løst problemet, men der er desværre ingen udsigt til, at de får implementeret en løsning i den nærmeste fremtid.

NB! Hvis du ønsker at tilbyde fri fragt over et bestemt beløb, så skal du anvende automatisk rabat til fragt, der er beskrevet i denne vejledning. Denne løsning vil tage højde for rabatkoder samt betalingsløsninger som Apple Pay, Google Pay eller lignende.

Fragtberegning ved flere lokationer

Problem:

Benytter du flere lokationer i Shopify, vil du på ordrer, hvor der er varer fra flere lokationer opleve, at fragtprisen bliver beregnet pr. lokation og lagt sammen.

Årsag:
Problemet skyldes, at Shopify sender web requests med forskellige "origin" (lokationer). Da der er tale om forskellige web requests og vi benytter flere parallelle servere, så er det en udfordring, som vi ikke kan lave en god løsning på.

Status:​
Vi rykker jævnligt Shopify for at få løst problemet, men der er desværre ingen udsigt til, at de får implementeret en løsning i den nærmeste fremtid.

Besvarede dette dit spørgsmål?