Shipmondo app for Shopify har nogle begrænsninger, som skyldes manglende understøttelse i Shopifys API. Disse mangler hos Shopify medfører, at Shipmondo appen i nogle brugsscenarier ikke fungerer hensigtmæssigt.
Herunder kan du læse om disse scenarier/begrænsninger:
Fragtgrænser baseret på kurvens totalpris og rabatkoder
Problem:
Benytter du fragtgrænser baseret på kurvens totalpris (Order amount based) med Shipmondo appen vil du opleve at Shipmondo appen ikke tager højde rabatkoder i sin prisberegningslogik.
Årsag:
Problemet skyldes, at Shopify API ikke videregiver informationer om rabatter i checkout til os. Dermed får vi kun opgivet den samlede normalpris eksklusiv eventuelle rabatter.
Status:
Der er en igangværende dialog med Shopify, og vi afventer stadig en løsning på problemet. Desværre er der ingen fastlagt tidsramme eller estimeret tid for, hvornår en løsning kan tilbydes.
NB! Hvis du ønsker at tilbyde fri fragt over et bestemt beløb, så skal du anvende automatisk rabat til fragt, der er beskrevet i denne vejledning. Denne løsning vil tage højde for rabatkoder samt betalingsløsninger som Apple Pay, Google Pay eller lignende.
Fragtberegning ved flere lokationer
Problem:
Benytter du flere lokationer i Shopify, vil du på ordrer, hvor der er varer fra flere lokationer opleve, at fragtprisen bliver beregnet pr. lokation og lagt sammen.
Årsag:
Problemet skyldes, at Shopify sender web requests med forskellige "origin" (lokationer). Da der er tale om forskellige web requests og vi benytter flere parallelle servere, så er det en udfordring, som vi ikke kan lave en god løsning på.
Status:
Der er en igangværende dialog med Shopify, og vi afventer stadig en løsning på problemet. Desværre er der ingen fastlagt tidsramme eller estimeret tid for, hvornår en løsning kan tilbydes.
Manglende valg af pakkeshop gennem Apple og Google Pay
Problem:
Kunden kan ikke vælge en specifik pakkeshop til levering, når der bruges Apple Pay eller Google Pay.
Årsag:
Vi modtager ikke de nødvendige modtageroplysninger, da Shopify ikke har adgang til disse data og derfor ikke kan videregive dem til vores system.
Dette betyder, at kunden ikke kan vælge en specifik pakkeshop til levering. Pakken vil dog stadig blive leveret til den nærmeste pakkeshop baseret på kundens adresse.
Status:
Der er en igangværende dialog med Shopify, og vi afventer stadig en løsning på problemet. Desværre er der ingen fastlagt tidsramme eller estimeret tid for, hvornår en løsning kan tilbydes.